You're seeing this message because you're using an older version of Internet Explorer that is unsupported on our website. Please use these links to upgrade to a modern web browser that fully supports our website and protects your computer from security risks.

Mozilla Firefox

Mozilla Firefox

Google Chrome

Google Chrome

Internet Explorer 8

Hide this message

FSU Tag Line
 

Computer and Browser Requirements for PAWS

PAWS will function on platforms meeting the manufacturer's requirements for a given web browser and operating system combination.

Browser Requirements for PAWS (Certified by Oracle on the following operating systems)

Internet Explorer 10 (Windows 8 [64-bit], Windows 7)
Internet Explorer 9 (Windows 8 [64-bit], Windows 7, Vista)
Internet Explorer 8 (Windows 8 [64-bit], Windows 7, Vista)
Internet Explorer 7 (Vista)

Safari 7 (Mac OSX 10.9)
Safari 6 (Mac OSX 10.8 [64-bit], Mac OSX 10.7 [64-bit])
Safari 5 (Mac OSX 10.6 [64-bit], Mac OSX 10.5 [32-bit], Mac OSX 10.4)
Safari 4 (Mac OSX 10.6 [32-bit], Mac OSX 10.5 [32-bit], Mac OSX 10.4)
Safari 3 (Mac OSX 10.6 [64-bit], Mac OSX 10.5 [32-bit], Mac OSX 10.4)

Firefox (Windows 7, Windows Vista, Mac OSX 10.7 [64-bit], Mac OSX 10.6 [64-bit], Mac OSX 10.5 [32-bit])

Chrome (Windows 7, Windows Vista)


Questions or Problems?

If you have any questions or problems while using any of the online services or PAWS, please contact the IT FSU Help Desk (301-687-7777).