You're seeing this message because you're using an older version of Internet Explorer that is unsupported on our website. Please use these links to upgrade to a modern web browser that fully supports our website and protects your computer from security risks.

Mozilla Firefox

Mozilla Firefox

Google Chrome

Google Chrome

Internet Explorer 8

Hide this message

FSU Tag Line
Header Image
 

PC Requirements for PAWS

PAWS will function on platforms meeting the manufacturer's minimum requirements for a given web browser and operating system combination. You will experience better results if you have a workstation that exceeds the minimum requirements.


Browser Requirements for PAWS
 

  • Internet Explorer 6 on Windows 98, NT 4, Windows 2000, and Windows XP
  • Internet Explorer 5 on Mac OS 7.5 and above
  • Netscape Communicator 4.72 on Mac OS 7.6.1 and above
  • Netscape Navigator 6.2 on Mac OS 9/X
  • Netscape Communicator 4.72 on Linux


Questions or Problems?

If you have any questions or problems while using any of the online services or PAWS, please contact the FSU Help Desk (301-687-7777).